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Disclaimer 
Before starting any diet, weight management or exercise program, it is advisable to consult your 
doctor. The instructions and advice given here, and the use of this program, are in no way 
intended as a substitute for medical counselling. 
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RMRDiet Overview 
RMRDiet ‘Diet/Weight/Exercise Tracker’ allows you to monitor a diet and weight loss (or 
control) programme by tracking foods consumed, nutrient intake, your weight profile, and your 
exercise regime. There are 6 different screen views: 

Diet view allows entry and viewing of food consumption by days and meal 
periods. 

Nutrient monitor shows tracking bars for the calories and nutrients. 

Weight view allows entry and viewing of weight and body measurements by date. 

Weight monitor shows a graph of your weight against the target profile. 

Exercise view allows entry and viewing of exercise and occupation activities to track 
calorie burn targets. 

Exercise monitor shows tracking bars of your daily calorie expenditure. 

To switch between the views, select them from the View > Switch view menu or CBA button, or 
use Ctrl+Q. 

Moving around RMRDiet 
Use: 

• Up/Down arrow keys to select entries. 
• PgUp/PgDn to move a screenful at a time. 
• Home/End to go to the top or bottom entry in the file. 
• Ctrl+L to go to a date 
• Ctrl+Q to switch View between all the screens. 
• L/R arrow keys to move through days. 

Program setup 
When you start the program for the first time (once past the Register nag screen) you will be 
guided through a series of setup screens prompting you to enter: 

• Preferences. 
• User details. 
• Weight Targets. 

From all these details the program will calculate your required daily Nutrient Targets needed to 
reach your target weight. 

• You can change these Nutrient targets if required and add any Custom nutrients you 
wish to use. 

Later you can use these same options from the Tools menu to change any of the information if 
needed. 

Entering your user details 
Your personal details are required for diet calculations, and are requested when the program is 
first run. 

• Name. This is shown in the titlebar for naming purposes. 
• Sex, 
• Height (units are defined in Preferences), 
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• Age, 
• and the Activity level that best fits your lifestyle, as Sedentary, Light active, Moderately 

active, Very active, Extra active. Note that these are subjective judgement values – be 
honest! 

Entering your weight targets 
Your personal weight loss targets are required for diet calculations, and are requested when the 
program is first run. Later you can use Tools > Targets, Ctrl+T, to change your weight loss 
profile if needed. Enter: 

• the Start date for your diet, 
• your Start weight, (units for weight are defined in Preferences), 
• your Goal weight, 
• the amount of weight per week you want to lose. 

The usual medical recommendation is not to attempt more than 2 pounds (1kg) weight loss per 
week. 

When you select OK from CBA, your user details and weight targets are used to calculate your 
required daily Nutrient targets, viewed in the next dialog. 

Entering your nutrient targets 
There are so many different types of diets around that it is impossible to predict exactly what 
daily nutrient targets you need for your specific diet. For example, the carbohydrate level for the 
Atkins Diet is very different from a Weight Watchers diet. 

So, the program sets nutrient targets based on a generic, well balanced, standard diet but 
allows you to modify the values if you have accurate information for your diet type. 

When you use Tools > Targets, Ctrl+T, there is a second dialog (after entering the weight 
details) where you can view the Nutrient targets the program has allocated to you. 23 values 
are available : 

calories protein fat carbohydrates 
fibre sugar calcium iron 
magnesium potassium sodium zinc 
vitamin C thiamine riboflavin vitamin B6 
vitamin B12 vitamin A vitamin E vitamin K 
saturated fat unsaturated fat cholesterol. 

Note that these use a range of different units, either gm, mg or µg. 

• Amend any of the values if you have more accurate knowledge for your personal situation. 
• If you make a mess of it the Default values button will reset them back. 
• In addition, 5 custom values can be added by the user. Use the Custom nutrients button 

to set the Names and Values for these. 

Entering custom nutrients 
The last 5 nutrients in Targets can be user defined for your special requirements, for example to 
record Weight Watchers points. Use Tools > Targets, Ctrl+T, and access the Custom 
nutrients button from the second Nutrient targets dialog, then define: 

• the Nutrient name, 
• the Units to be used. 
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Registering the program 
If you wish to register your copy, which will then give you full access to the program, and no nag 
screen, the cost is £20 or €30 or US$30. There are several ways to register: 

Credit Card: 
If you wish to register on-line using a credit card you have 2 options: 

PAYPAL: 
We now support the PayPal system for transferring of money, as that avoids the $5 handling 
charge put on by REGNET. Simply send the money to registrations@rmrsoft.com quoting the 
program name, RMRBank (UIQ), and we will send the registration code to you within a few 
hours. 

If you are not already signed up for PayPal it is very straightforward. Just go to www.paypal.com 
and follow the instructions. You even get a $5 bonus for signing up. 

REGNET: 
Alternatively, you can register on the WWW through RegNet, the Registration Network (note 
that paying by this method will involve an extra US$5 handling charge and if you live in the EU 
they will also charge VAT). RegNet can be reached by e-mail: orders@reg.net or on the World 
Wide Web: http://www.reg.net or in the USA by calling 1-800-WWW2REG (1 800 999-2734) or 
the easiest way is by following the links from our Home page at: 

http://www.rmrsoft.com/ 

RMRDiet (Nokia) has been allocated the RegNet Number 14774 and this should be quoted. The 
notification tends to get to us within 12 hours and we reply within another 12 hrs. 

By Post: 
Payment can be made by post as: 

• UK cheque in GBP (NO cheques in foreign currencies or on non-UK banks) 
• International Bankers Draft in Sterling 
• Cash - 'real folding' money in any currency 
• US$ checks (send to the USA address) 

Please make any cheques (checks) payable to 'RMR Software' and include a stamped, self-
addressed envelope or provide an E-Mail address, and send to either of these addresses: 

RMR Software 
c/o 46 Mortimer Road 
Kempston 
Bedford MK42 8RE 
ENGLAND 
 

RMR Software  
c/o 6000 Natick Court 
Burke, VA 22015 
USA 

We will then send you a unique code to enter with the Register menu option, which will allow 
you unrestricted use of the program. 

If you have any questions, we can be contacted at  support@rmrsoft.com 

mailto:registrations@rmrsoft.com
http://www.rmrsoft.com/
mailto:support@rmrsoft.com
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Diet view 
The Diet view screen shows your record of individual foods consumed, listed with the name of 
the food, the serving quantity, and its calorie and nutrient values. Select which 6 nutrients from 
the complete range you wish to display using the Tools > Diet preferences > Nutrients 
columns menu option. Each column is totalled for the day at the bottom of the screen. 

Use the options in the Edit menu to add, update and delete food entries. Use the options in the 
Food menu to modify the foods database or to create pre-defined meals. 

The date is displayed in the bottom left corner. Use the left and right arrows to move back and 
forward one day, or the Go to date CBA button to get the popup calendar. 

Under the Data menu there are Backup and Restore options. Use these to keep a copy of your 
Diet data elsewhere on the system for security, and to get it back if necessary. 

Entering diet food records 
Each time you eat something record it in the Diet screen with Edit > Add food entry or Ctrl+A 
or the Add entry CBA button, or Enter key, and complete the following details: 

• Date, usually for today, but entries can be added for past days. 
• Time of Meal period. This can be specified as Breakfast, Morning snack, Lunch, 

Afternoon snack, Dinner, Evening snack, or <None> to just record the details if timing 
is not important. 

• Category of food from the database. 

Then use the Done button and in the next screen additionally select: 

• Food Name within the category. 
• Units of measurement for quantity of the food. 
• Serving size in multiples of the selected unit. 

The food item will then be entered onto the screen (assuming the date and any filter applied to 
the display match the input values). 

Note: The default installation provides an example database of about 1000 typical foods to 
give you a start and allow you to test the program. However, this is just a sample of the full 6000 
standard Food Data items available as a CSV format file (comma separated values) available 
for free download from our website. See the Modifying Databases section of this manual for a 
full description on how to set up your preferred food database. 

Updating diet food entries 
To correct any food entries in the Diet screen, move the highlight to the required entry and use 
Edit > Update food entry or Ctrl+U. 
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Change the Date or Meal period, food Category, and then the food Name, Units of 
measurement and Serving size as required. The dialog is effectively the same as when adding 
food entries. 

Deleting diet food entries 
To delete a food entry, move the highlight to the required entry and use Edit > Delete food 
entry or Ctrl+D. 

Filtering the Diet view meal periods 
When you enter foods or meals you can record the time when you consumed the foods, with the 
day subdivided into meal periods for: 

• Breakfast 
• Morning snack 
• Lunch 
• Afternoon snack 
• Dinner 
• Evening snack 

You can then use the Filter diet entries, Ctrl+F, menu option to select the Meal time to view. 
Only entries matching this period will be displayed and totalled on screen. The titlebar text will 
change to indicate the meal period being viewed, example “Diet breakfasts”. 

Reset the filter to <None> to view all the day’s entries again. 

Meals 

Creating meals from food items 
The Meals options allow you to automate and simplify the food recording process by entering a 
collection of foods as a single entry. Use this when you regularly find yourself adding the same 
foods and quantities at the same time. To create a meal: 

1. First use Add food entry in the normal way to enter all the individual foods that make up 
a particular meal, with the correct quantities. 

2. Once all the individual food items are displayed in the Diet screen, use the menu option 
Food > Add meal, Shift+Ctrl+F. 

3. Give the meal a meaningful Name and click Done to save all the foods as a single 
consolidated entry. 

Afterwards you can use the menu option Edit > Add meal entry, Shift+Ctrl+M, to simply add all 
the component foods of the meal automatically on screen together. 

Updating meals 
There is no specific “Update meal” function. However, to accomplish this, enter the meal with 
Edit > Add meal entry on an empty day screen to see all the component foods. Delete, add or 
update the quantities of the foods as required, and then use the Add meal menu option to 
create the meal with a new name. Then delete the old meal name if no longer needed. 

Deleting meals 
If you have created pre-set meals that you no longer want, use the Food > Delete meal menu 
option, Shift+Ctrl+C, to completely remove it. 
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Note: This will not remove the individual component foods from the database. 

Adding meals as entries 
First set up your meals containing a range of food items. (See the Creating meals item above.) 

Afterwards you can use the menu option Edit > Add meal entry, Shift+Ctrl+M, to automatically 
add all the foods at once in the Diet screen. Simply select: 

• Date, usually for today, but meals can be added for past days. 
• Time of Meal period. This can be specified as Breakfast, Morning snack, Lunch, Afternoon 

snack, Dinner, Evening snack, or <None> to just record the details if timing is not 
important. 

• Name of the meal from those you have set up. 

Nutrient monitor view 
This monitor screen displays your current consumption of 6 selected nutrients compared to your 
target intake for the day. 

Use the Nutrients progress bars menu option to set which 6 nutrients are shown. 

The screen shows the data in three ways: 

• yellow bars indicate the 100% amount of the nutrient intake, with your actual intake shown 
as a progressing black bar. These turn red when 100% is exceeded. 

• the Intake column shows the actual consumption value vs the target amount. 
• as a consumption Percentage. 

The date is indicated in the header bar. Use the left and right arrows (or up and down) to move 
back and forward one day, or the Go to date CBA button to get the popup calendar. 

Food database 

Adding food items to the database 
The default installation provides an example database of about 1000 typical foods. You can add 
to this from the full 6000 standard Food Data items available as a CSV format file for free 
download from our website. See the Modifying Databases section of this manual. 

Alternatively, you can manually add your own food items individually. Use the Food > Add food 
item menu option, Shift+Ctrl+A: 

• first select an existing food Category to add it to. 
• give the food a descriptive Name. 
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• tap the Done CBA button 
• complete the food item details in the next screen with the calorie, fat, fibre and other 

nutrient values. 

Note: The required units are shown for each item. Remember that values are the amount of 
nutrient in a 100gm serving of the food. 

If you want a new category use the Add food category menu option beforehand. 

Updating food items in the database 
Use the menu option Food > Update food item, Shift+Ctrl+U, to make changes to the foods in 
the default database supplied with the program. 

• select the Category and Name of the food, and click Done. 
• then in the next dialog, amend the Name, and adjust the Nutrients as required. 

For bulk changes to the database it is better to export as CSV file, modify in a spreadsheet 
program, and then re-import. See the Export and Import, and Modifying Databases sections of 
this manual for a full description on how to set up your preferred food database this way. 

Deleting food items from the database 
If you no longer want a particular food item in the database (or wish to remove unused foods to 
save space), use the menu option Food > Delete food item, Shift+Ctrl+D. Select the required 
Category and Name of the food and click Done. 

For bulk changes to the database it is better to export as CSV file, modify in a spreadsheet 
program, and then re-import. See the Export and Import and Modifying Databases sections of 
this manual for a full description on how to set up your preferred food database this way. 

Adding food categories to the database 
If you wish to use a different food category which is not present in the existing database, you 
will need to create it manually before adding foods items to it. 

Use the Food > Add food category menu option, Shift+Ctrl+Q, and enter the new Category 
name. 

Weight view 
This screen is where you record your weight and body measurements. 

For each individual dated entry, there are columns to show your weight, weight change from the 
previous entry (-ve is a weight loss), your body fat measurement, and 5 body measurements for 
chest, waist, hips, biceps, and forearm. 

Use the options in the Edit menu to add, update and delete weight entries. 
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The bottom window bar displays your Start weight and Goal weight taken from your Targets, 
together with the calculated Overall weight loss. 

Use the up and down arrows to move back and forward through the days, or the Go to date 
CBA button to get the popup calendar. 

Entering weight records 
You should regularly record your weight so you can check your progress against the target 
profile. In the Weight view use Add weight, Ctrl+A, or the Add entry CBA button, or Enter key, 
and complete the following details: 

• Date 
• Weight 
• Body fat 
• Chest, Waist, Hips, Biceps, Forearm measurements. 

You can ignore any of the measurements you do not wish to use. 

Updating weight entries 
To correct any weight entries in the Weight screen, move the highlight to the required entry and 
use Edit > Update weight or Ctrl+U. 

Change the Date, Weight, or Body Measurements as required. The dialog is effectively the 
same as when adding weight entries. 

Deleting weight entries 
To delete a weight entry, move the highlight to the required entry and use Edit > Delete weight 
or Ctrl+D. 

Weight monitor view 
This monitor screen displays a graph of your weight records, and your weight loss progress 
towards your goal weight. 

The top bar is the time X-Scale from your Start date on the left to the Goal date on the right. 
The Y-axis is your Start weight and Goal weight calculated from the loss per week required. 
Together the values from your Targets give the constant weight loss diagonal profile line. 

As you enter your weight records you can track your weight loss progress against the goal 
profile. 
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Exercise view 
This screen is where you enter and view details of your exercise and occupation activities to 
track calorie burn targets. 

It shows your individual entries of exercise activities taken on specific dates, with columns 
recording the duration Time, the calculated Calories burnt, and the cumulative Total calories 
burnt for the day. The bottom bar indicates a running Average burn from the start date. 

Use the options in the Edit menu to add, update and delete exercise entries. Use the options in 
the Activities menu to modify the exercise database. 

The date is displayed in the bottom left corner. Use the left and right arrows to move back and 
forward one day, or the Go to date CBA button to get the popup calendar. 

Entering exercise records 
Each time you exercise or perform a work activity record it in the Exercise screen with Edit > 
Add exercise or Ctrl+A or the Add entry CBA button, or Enter key, and complete the following 
details: 

• Date, usually for today, but entries can be added for past days. 
• Category of the exercise type. 

Then in the next screen additionally select: 

• The exercise Name from the database 
• Length of Time in minutes the exercise was done. 

The exercise entry will then be displayed on the screen (provided the display date matches the 
input date). 

Note: The default program installs a reasonable database of exercises to give you a start 
and allow you to test the program. Like the food database, you may need to build a more 
complete database of exercises that suit your particular needs. 

Updating exercise entries 
To correct any activity entries in the Exercise screen, move the highlight to the required entry 
and use Edit > Update exercise or Ctrl+U. 

Change the Date or activity Category, and then the exercise Name and/or the length of Time 
as required. The dialog is effectively the same as when adding exercise entries. 

Deleting exercise entries 
To delete am exercise entry, move the highlight to the required entry and use Edit > Delete 
exercise or Ctrl+D. 
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Exercise monitor view 
This monitor screen displays a bar graph of your energy burned each day, allowing you to track 
an overall exercise program. 

The header shows a calorie scale for the Energy spent. Below this, yellow daily bars show your 
actual calorie burn from exercises as a progressing black bar. 

The past seven days are always shown, but use the left and right arrows (or up and down) to 
move back and forward through the days, or the Go to date CBA button to get the popup 
calendar. 

Exercise database 

Adding exercise activities to the database 
The default installation provides an example database of exercises and activities. If these are 
not sufficient you can manually add your own activities to the database. Use the Activities > 
Add activity menu option, Shift+Ctrl+A, and: 

• first select an existing exercise Category to add it to. 
• give the exercise a descriptive Name. 
• enter the burn rate in Calories/minute. You will need to obtain this from an appropriate 

source. 

If you want a new category use the Add activity category menu option beforehand. 

Updating exercise activities in the database 
Use the menu option Activities > Update activity, Shift+Ctrl+U, to make changes to the 
exercises and activities in the default database supplied with the program. 

• select the Category and Name of the activity and click Done. 
• in the next dialog, amend the Name and/or adjust the Calories/minute value as required. 

For bulk changes to the database it is better to export as CSV file, modify in a spreadsheet 
program, and then re-import. See the Export and Import and Modifying Databases sections of 
this manual for a full description on how to set up your exercise database this way. 

Deleting exercise activities from the database 
If you no longer want a particular exercise or activity in the database (or wish to remove unused 
types to save space), use the menu option Activities > Delete activity, Shift+Ctrl+D. Select the 
required Category and Name and click Done. 



  RMRDiet (for Nokia Communicator) Diet/Weight/Exercise Tracker 

www.rmrsoft.com page 14 

For bulk changes to the database it is better to export as CSV file, modify in a spreadsheet 
program, and then re-import. See the Export and Import and Modifying Databases sections of 
this manual for a full description on how to set up your exercise database this way. 

Adding activity categories to the database 
If you wish to use a different category of exercise or activity which is not present in the supplied 
database, you will need to create it manually before adding items to it. 

Use the Activities > Add activity category menu option, Shift+Ctrl+Q, and enter the new 
Category name. 

Other functions 

Go to date 
Use Go to date, Ctrl+L, to go directly to a specific date in the Diet, Weight or Exercise views 
and their Monitor screens (except Weight), using the calendar selector. This is an alternative to 
using the Left and Right arrow keys to move through each day in turn. 

Displaying your BMI, BMR and BEE 
Use the Tools menu options to view the indexes associated with your weight and energy 
usage. 

• BMI – your "Body Mass Index" and how it relates to the ideal. You should be aiming to get 
it into the “Low” area. 

• BMR – your “Basal Metabolic Rate”, the calories burned at complete rest. 
• BEE – your “Basic Energy Expenditure”, the calories burned for your defined activity level. 

Resetting the start date 
In the interests of speed and memory usage, you should regularly remove outdated data. 

The Tools > Reset start date option, Ctrl+H, is available in all the screens. This allows you to 
set a new start date for the files, and delete all earlier entries from the history. 

You may wish to use the Export data options (from each of the Diet, Weight and Exercise 
screens) first to save your personal history details to an ascii or csv text file. 
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Exporting your diet history data 
You can save your personal history data from each of the screens to a text file. Use Export diet 
data in the Data menu of Diet view, Export weights in Weight view, and Export exercise data 
in Exercise view, or Shift+Ctrl+K, and: 

• Select whether to export as ASCII (Tab delimited) or CSV (Comma Separated Variable) 
format. 

• For the Diet view you can also select Start and End dates and the Meal period to export. 

The name of the output file will be the ‘User name’ followed by the screen name (Diet, Weight, 
Exercise), e.g. John-Diet.txt and will be saved in the C:\My files\RMRDietfolder\Export folder on 
your Communicator. 

The files can then be used in the built-in applications, or copied off your phone for use in other 
PC programs. 

Backup and Restore data 
Under the Data menu there are Backup data and Restore data options. 

Backup data, Shift+Ctrl+B, allows you to keep a copy of your RMRDiet data elsewhere on the 
system for security. 

ALL the data from ALL the screens is backed up so there is no necessity to action this from 
each screen in turn. 

If necessary in the case of data loss, use Data > Restore data, Shift+Ctrl+R, to restore all 
datafiles. 

Note: All current data in the program will be overwritten by restoring the backed up data. 

Program configuration 

Setting RMRDiet program preferences 
Use the Tools > Preferences option, Ctrl+K, to configure the program: 

• Start screen. Which of the three main views, Diet, Weight or Exercise, you want the 
program to open into. 

• The Date format for the screen display, from a range of international formats. 
• The Height units to be used for body measurements and calculations, either inches or 

centimetres. 
• The Weight units to be used for entering and displaying targets and weight 

measurements, either pounds or kilograms. 
• The Decimal places to be used for display of data values. 

Setting screen preferences 
Each screen has a Diet, Weight or Exercise preference menu option where you can set the 
Colour of the Header/Bottom window. This can be different in each screen. 

Setting Diet view nutrients columns 
The supplied food database provides 23 energy, fat, nutrient and trace element values for each 
food item: 
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• Calories, protein, fat, carbohydrates, fibre, sugar, calcium, iron, magnesium, potassium, 
sodium, zinc, vitamin C, thiamine, riboflavin, vitamin B6, vitamin B12, vitamin A, vitamin E, 
vitamin K, saturated fat, unsaturated fat, cholesterol. 

• In addition, 5 custom values can be added by the user. 

The Diet view can display any 6 of these values in the columns. Use the Tools > Diet 
preferences > Nutrients columns menu option to specify which nutrient you wish to display in 
each column. 

Note: You can ignore the nutrients you do not wish to use. 

Setting Diet monitor nutrients bars 
In the Diet monitor view, use the Nutrients progress bars menu option to set which 6 
nutrients are shown for the consumption progress bars. These should be the key or most 
meaningful nutrients you wish to monitor for your diet. 

Nutrients can be different to those displayed in the Diet screen columns. 

Modifying databases 

Foods database 
The default program installation provides an example database of about 1000 typical foods to 
give you a start and allow you to test the program. However, this is just a sample from the full 
list of 6000 generic and commercial Food Data items sourced from the USDA (US Dept of 
Agriculture) together with their energy and nutrient values for a 100gm serving. This is available 
as "Master Food File.csv", a CSV format file (comma separated values), for free download from 
our website at http://www.rmrsoft.com/. 

For ease of use and upgrading, the format of our database follows the same format as the 
actual USDA database available from the USDA website, except the first column is changed 
from "NDB_No" to "Category". The format is as follows: "Category", "Description",… then a list 
of nutrients with the units used (either gm, mg or µg) and the values, which relate to the amount 
of the nutrient in a 100gm serving. 

The USDA database contains 43 nutrients, but the Symbian OS only allowed us to use 28 
nutrients. So we picked the most likely 23 nutrients and then as discussed elsewhere used the 
remaining 5 nutrients as "user-defined" so you can decide which extra ones you want, or 
perhaps some other reading such as Weight Watcher points. 

Obviously this default trial database of 1000 foods will not be suitable for all users, so to get the 
best from the program you need to build a more complete database of foods that suits your 
particular needs. There are three methods : adding, updating or deleting individual items in the 
program; making bulk changes to the CSV file; or creating your own database from scratch. 
Descriptions of each follow: 

Manually amend individual food items 
Use the menu options Food > Add food item / Update food item / Delete food item (as 
described elsewhere in this manual) to make changes to the trial database. 

http://www.rmrsoft.com/
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If you are adding a food you first need to select the Category then give a Name (Description) 
for the food, and fill in all the Nutrients values. The required units are shown on the screen, and 
remember the value is the amount of nutrient in a 100gm serving of the food. 

To update a food follow the same procedure, selecting the Category, renaming the Name, and 
adjusting the Nutrients. 

Make bulk database changes 
We would suggest that importing all 6000 foods in the master database to the program is 
unnecessary. For storage and speed considerations it is probably a good idea to use as 
compact a database as possible containing only those foods that you normally consume. 
However, there should be plenty of room, as the trial food database only takes up 200 Kb. A 
database of 2000 foods should be easily handled and quite practical. 

Probably the most practical and effective method is to edit the supplied master CSV file (Master 
Food File.csv) in a spreadsheet program or text editor on your PC. Remove the foods you know 
you don't need, add any new foods you want, or change the names of the foods to be more 
suitable (some of the USDA names are rather long-winded!). 

Note : RMRDiet assumes that foods are grouped by Category. If a Category occurs in 2 
different places in the CSV file it will show up twice in the selection dialog. Some sorting may be 
necessary. 

Then import the revised CSV into RMRDiet as described below. 

Create your own database 
Alternatively you can of course create your own Food.csv data file from scratch if you have your 
own source of food nutrient information. 

Just use a spreadsheet program to list the food category, descriptions and nutrient details (per 
100gm serving) in the same format as the master file, then import it as described below. 

Importing foods to the database 
Once the CSV file has been amended or created: 

1. Copy it to any folder on your Communicator for import. 

2. Use the program menu option Data > Import food items, in Diet view, or Shift+Ctrl+I 

3. Navigate to the CSV file in the ‘Open files’ screen. Click on the OK CBA to import the 
data. 

Note : this action will completely overwrite the existing database so make sure you use this 
option with care. 

The import operation can take some time, something like 5 entries a second (the sample 
database imports in about 2 minutes), so please be patient. 

Exercise database 
The program installs a reasonable database of exercises and lifestyle activities to give you a 
start and allow you to test the program. But like the foods database, to get the best from the 
program, you probably need to build a more complete database of exercises that suit your 
particular needs. 

The creation process and options, and import methods are identical to that described above for 
the Foods database, except the master file is called “Exercises.csv”, and the Import activities 
menu option is in the Exercise view. 



  RMRDiet (for Nokia Communicator) Diet/Weight/Exercise Tracker 

www.rmrsoft.com page 18 

Exporting food and exercise databases 
After initial setup of your foods and exercises databases as described above, you can maintain 
it on the Communicator using the add, update and delete options on single items. 

If you need to make more radical changes, you can of course export your current food and/or 
activity database (with your existing changes) from RMRDiet back to an external CSV file for 
further editing on PC. 

You can also export your databases to copy off your Communicator device so that you can 
share the foods and activities that you have created or modified yourself with your family and 
friends. 

To export your database: 

1. Use the program menu option Data > Export food items (or Shift+Ctrl+J) in Diet view to 
export your food database. 

2. Or use Data > Export activities in Exercise view to export your exercise activities 
database. 

3. “Food.csv” and “Exercise.csv” files will be created in the C:\My files\ RMRDietfolder\ 
Export folder on your Communicator. 

4. Copy these back to a PC for editing in a spreadsheet program. 

5. Repeat the Import stage if you want to bring the revised data back into RMRDiet. 
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